Re: [PATCH v4 1/2] selftests/mm: rename local_config.h to local_config.h_gen

From: SJ Park

Date: Mon Aug 03 2026 - 19:59:03 EST


Hell Pratyush,


My recipients checker found you are using the old email address of Liam, so
added Liam's updated email to the recipients list.

On Mon, 3 Aug 2026 22:17:31 +0000 pratmal@xxxxxxxxxx wrote:

> From: Pratyush Mallick <pratmal@xxxxxxxxxx>
>
> Because local_config.h is a generated build artifact, un-ignoring all
> .h files in .gitignore causes it to incorrectly show up as an untracked
> file in git status.
>
> Rename it to local_config.h_gen so it no longer matches the !*.h
> inclusion rule, preparing for a subsequent patch that switches
> .gitignore to a pattern-matching approach.
>
> Update Makefile, check_config.sh, and affected test sources (cow.c,
> gup_longterm.c) accordingly.

Looks good to me. Thank you for accepting my humble suggestion or reordering.

I found this patch cannot cleanly 'git am'-ed on mm-new, mm-unstable and even
mm-stable. Maybe rebasing will be nice?

>
> Reviewed-by: Lorenzo Stoakes <ljs@xxxxxxxxxx>
> Acked-by: Mike Rapoport (Microsoft) <rppt@xxxxxxxxxx>
> Suggested-by: David Hildenbrand <david@xxxxxxxxxx>
> Signed-off-by: Pratyush Mallick <pratmal@xxxxxxxxxx>

Reviewed-by: SJ Park <sj@xxxxxxxxxx>


Thanks,
SJ

[...]