[PATCH] MAINTAINERS: move mm/folio.c to MM CORE

From: Jianyue Wu

Date: Tue Aug 04 2026 - 07:24:59 EST


mm/folio.c holds generic folio LRU helpers, not MGLRU-specific
code. Move it to MEMORY MANAGEMENT - CORE, next to
folio-compat.c and folio_batch.h, so get_maintainer.pl routes
reviews to the right people.

Fixes: 8ed6d702d442 ("mm: rename swap.c to folio.c")
Suggested-by: Lorenzo Stoakes <ljs@xxxxxxxxxx>
Signed-off-by: Jianyue Wu <wujianyue000@xxxxxxxxx>
---
MAINTAINERS | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/MAINTAINERS b/MAINTAINERS
index 2657cbf6df90..e9c8567308a7 100644
--- a/MAINTAINERS
+++ b/MAINTAINERS
@@ -16990,6 +16990,7 @@ F: kernel/fork.c
F: mm/Kconfig
F: mm/debug.c
F: mm/folio-compat.c
+F: mm/folio.c
F: mm/highmem.c
F: mm/init-mm.c
F: mm/internal.h
@@ -17091,7 +17092,6 @@ F: Documentation/admin-guide/mm/multigen_lru.rst
F: Documentation/mm/multigen_lru.rst
F: include/linux/mm_inline.h
F: include/linux/mmzone.h
-F: mm/folio.c
F: mm/vmscan.c
F: mm/workingset.c

--
2.43.0