Re: [PATCH 1/2] x86: Use IS_ENABLED() for built-in-or-module checks

From: Ingo Molnar

Date: Tue Aug 04 2026 - 13:52:49 EST



* Thorsten Blum <thorsten.blum@xxxxxxxxx> wrote:

> Replace open-coded built-in-or-module checks for CONFIG_APM, CONFIG_EDD,
> and CONFIG_X86_SPEEDSTEP_SMI with IS_ENABLED().

Please include the phrase "No change in functionality intended." or so
in the changelog, when there's no side effect expected.

Thanks,

Ingo