Re: [PATCH v2 01/10] ceph: add ceph_folio_snap_context()
From: Zi Yan
Date: Tue Aug 04 2026 - 16:03:50 EST
On 4 Aug 2026, at 14:52, Tal Zussman wrote:
> Add a folio-based counterpart to page_snap_context() that reads the
> snap context from folio->private directly.
>
> Convert the three writeback paths that passed &folio->page to
> page_snap_context() to ceph_folio_snap_context(), removing three
> open-coded folio-to-page conversions. No functional change.
>
> Signed-off-by: Tal Zussman <tz2294@xxxxxxxxxxxx>
> ---
> fs/ceph/addr.c | 12 +++++++++---
> 1 file changed, 9 insertions(+), 3 deletions(-)
>
Acked-by: Zi Yan <ziy@xxxxxxxxxx>
Best Regards,
Yan, Zi