Re: [PATCH v2 3/4] selftests: mm: implement the mTHP-sized hugepage check helpers

From: Nico Pache (Red Hat)

Date: Tue Aug 04 2026 - 16:42:31 EST


> Implement mTHP-sized hugepage checking helpers using gather_folio_orders().
> Also rename the existing PMD-sized huge page check function to
> __check_pmd_huge() for clarity.
>
> Signed-off-by: Baolin Wang <baolin.wang@xxxxxxxxxxxxxxxxx>

LGTM!

Reviewed-by: Nico Pache (Red Hat) <nico.pache@xxxxxxxxx>

--
Nico Pache (Red Hat) <nico.pache@xxxxxxxxx>