Re: [PATCH v9 0/7] Switch Arm SMCCC firmware services to an SMCCC bus

From: Catalin Marinas

Date: Wed Aug 05 2026 - 05:52:39 EST


On Wed, Aug 05, 2026 at 12:02:48PM +0530, Aneesh Kumar K.V (Arm) wrote:
> Changes from v8:
> https://lore.kernel.org/all/20260707081351.1680209-1-aneesh.kumar@xxxxxxxxxx
> * Rebase onto the arm64 for-next/core branch.

Was there a dependency on anything in for-next/core? We normally apply
series on their own branch on top of the vanilla kernel (e.g. 7.2-rc3)
and merge everything together in for-next/core. We (and many other
maintainers) strongly prefer series posted on top of an -rc kernel
(typically -rc1 to -rc3) unless there's a dependency on a different
branch. Never based on -next or -next like branches (which is what
for-next/core is, as the name implies).

> * Move the RSI code from arch/arm64 to drivers/firmware/arm_rmm in patch 3.

Thanks for this.

--
Catalin