Re: [PATCH v3 3/4] selftests: mm: implement the mTHP-sized hugepage check helpers
From: Zi Yan
Date: Thu Aug 06 2026 - 10:59:44 EST
On 5 Aug 2026, at 23:34, Baolin Wang wrote:
> Implement mTHP-sized hugepage checking helpers using gather_folio_orders().
> Also rename the existing PMD-sized huge page check function to
> __check_pmd_huge() for clarity.
>
> Reviewed-by: Nico Pache (Red Hat) <nico.pache@xxxxxxxxx>
> Tested-by: Nico Pache (Red Hat) <nico.pache@xxxxxxxxx>
> Acked-by: Kiryl Shutsemau (Meta) <kas@xxxxxxxxxx>
> Signed-off-by: Baolin Wang <baolin.wang@xxxxxxxxxxxxxxxxx>
> ---
> tools/testing/selftests/mm/vm_util.c | 76 ++++++++++++++++++++++++++--
> 1 file changed, 72 insertions(+), 4 deletions(-)
>
LGTM.
Reviewed-by: Zi Yan <ziy@xxxxxxxxxx>
Best Regards,
Yan, Zi