Re: [PATCH] gpio: Use IRQ trigger mask helpers
From: Linus Walleij
Date: Thu Aug 06 2026 - 17:50:32 EST
On Sun, Aug 2, 2026 at 4:11 PM Maulik Shah <maulik.shah@xxxxxxxxxxxxxxxx> wrote:
> Use IRQ_TYPE_LEVEL_MASK and IRQ_TYPE_EDGE_BOTH instead of open-coded
> trigger type combinations in irqchip callbacks.
>
> No functional change intended.
>
> Assisted-by: Claude:claude-sonnet-5
> Signed-off-by: Maulik Shah <maulik.shah@xxxxxxxxxxxxxxxx>
Reviewed-by: Linus Walleij <linusw@xxxxxxxxxx>
Yours,
Linus Walleij