Re: [PATCH v2] iio: adc: bcm_iproc_adc: Convert probe() to use dev_err_probe()

From: Andy Shevchenko

Date: Thu Aug 06 2026 - 19:54:56 EST


On Thu, Jul 30, 2026 at 07:32:45PM +0530, mdshahid03@xxxxxxxxx wrote:

> Replace open-coded probe error handling with dev_err_probe() for
> resource acquisition and initialization failures.
>
> This simplifies the error paths, avoids repetitive error handling,
> and automatically suppresses duplicate messages when -EPROBE_DEFER is
> returned while preserving the existing error messages.
>
> Also remove the redundant error message after iproc_adc_enable(),
> allowing the error to be propagated without additional logging.

...

> static int iproc_adc_probe(struct platform_device *pdev)

While at it, consider adding

struct device *dev = &pdev->dev;

at the top of the function to simplify the below calls.

> adc_priv->regmap = syscon_regmap_lookup_by_phandle(pdev->dev.of_node,
> "adc-syscon");
> - if (IS_ERR(adc_priv->regmap)) {
> - dev_err(&pdev->dev, "failed to get handle for tsc syscon\n");
> - ret = PTR_ERR(adc_priv->regmap);
> - return ret;
> - }
> + if (IS_ERR(adc_priv->regmap))
> + return dev_err_probe(&pdev->dev,
> + PTR_ERR(adc_priv->regmap),
> + "failed to get handle for tsc syscon\n");

return dev_err_probe(dev, PTR_ERR(adc_priv->regmap),
"failed to get handle for tsc syscon\n");

> adc_priv->adc_clk = devm_clk_get(&pdev->dev, "tsc_clk");
> - if (IS_ERR(adc_priv->adc_clk)) {
> - dev_err(&pdev->dev,
> - "failed getting clock tsc_clk\n");
> - ret = PTR_ERR(adc_priv->adc_clk);
> - return ret;
> - }
> + if (IS_ERR(adc_priv->adc_clk))
> + return dev_err_probe(&pdev->dev,
> + PTR_ERR(adc_priv->adc_clk),
> + "failed getting clock tsc_clk\n");

And here, and so on...

...

> adc_priv->irqno = platform_get_irq(pdev, 0);
> if (adc_priv->irqno < 0)
> - return adc_priv->irqno;
> + return dev_err_probe(&pdev->dev,
> + adc_priv->irqno,
> + "failed to get IRQ\n");

This is wrong. The above call print an error.

> ret = regmap_clear_bits(adc_priv->regmap, IPROC_REGCTL2,
> IPROC_ADC_AUXIN_SCAN_ENA);
> - if (ret) {
> - dev_err(&pdev->dev, "failed to write IPROC_REGCTL2 %d\n", ret);
> - return ret;
> - }
> + if (ret)
> + return dev_err_probe(&pdev->dev,
> + ret,
> + "failed to write IPROC_REGCTL2\n");

It's a one line still (with the above change):

return dev_err_probe(dev, ret, "failed to write IPROC_REGCTL2\n");

> ret = devm_request_threaded_irq(&pdev->dev, adc_priv->irqno,
> iproc_adc_interrupt_handler,
> iproc_adc_interrupt_thread,
> IRQF_SHARED, "iproc-adc", indio_dev);
> - if (ret) {
> - dev_err(&pdev->dev, "request_irq error %d\n", ret);
> - return ret;
> - }

> + if (ret)
> + return dev_err_probe(&pdev->dev,
> + ret,
> + "failed to request IRQ\n");

This should be a separate patch to drop the dup message. The IRQ core prints
it.

...

> + return dev_err_probe(&pdev->dev,
> + ret,
> + "failed to enable clock\n");

One line.

--
With Best Regards,
Andy Shevchenko