[PATCH] platform/x86: olpc-xo15-sci: use named initializers for acpi_device_id

From: Pawel Zalewski via B4 Relay

Date: Fri Aug 07 2026 - 08:39:03 EST


From: "Pawel Zalewski (The Capable Hub)" <pzalewski@xxxxxxxxxxxxxxxxxxxx>

Use a named initializer for the acpi_device_id fields which
makes the code more readable and consistent with how lists
are initialized in the rest of the kernel code base. Also
drop explicitly setting fields to 0 where it is redundant.

While we are at it - unify the list terminator to have
a single space between the brackets and no trailing
comma.

Signed-off-by: Pawel Zalewski (The Capable Hub) <pzalewski@xxxxxxxxxxxxxxxxxxxx>
---
arch/x86/platform/olpc/olpc-xo15-sci.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/arch/x86/platform/olpc/olpc-xo15-sci.c b/arch/x86/platform/olpc/olpc-xo15-sci.c
index e486109e88c8..4b2dc77410a6 100644
--- a/arch/x86/platform/olpc/olpc-xo15-sci.c
+++ b/arch/x86/platform/olpc/olpc-xo15-sci.c
@@ -215,8 +215,8 @@ static int xo15_sci_resume(struct device *dev)
static SIMPLE_DEV_PM_OPS(xo15_sci_pm, NULL, xo15_sci_resume);

static const struct acpi_device_id xo15_sci_device_ids[] = {
- {"XO15EC", 0},
- {"", 0},
+ { .id = "XO15EC" },
+ { }
};

static struct platform_driver xo15_sci_drv = {

---
base-commit: f9a2394a23482bfd330911e9c8295b71724feacd
change-id: 20260807-acpi-platform-65fb522cf395

Best regards,
--
Pawel Zalewski (The Capable Hub) <pzalewski@xxxxxxxxxxxxxxxxxxxx>