Re: [PATCH 01/12] rust: io: add Region::try_subregion
From: Alexandre Courbot
Date: Fri Aug 07 2026 - 10:15:32 EST
On Wed Aug 5, 2026 at 7:43 PM JST, Gary Guo wrote:
> On Wed Aug 5, 2026 at 6:44 AM BST, Eliot Courtney wrote:
>> Add a helper to get a subregion of an IO view fallibly.
>>
>> Signed-off-by: Eliot Courtney <ecourtney@xxxxxxxxxx>
>> ---
>> rust/kernel/io.rs | 31 ++++++++++++++++++++++++++++++-
>> 1 file changed, 30 insertions(+), 1 deletion(-)
>
> Looks like the case where you need this don't actually require a `Region`
> (dynamically sized type) but rather a fixed size window?
>
> In that case the next version of
> https://lore.kernel.org/rust-for-linux/20260721-typed_register-v1-0-452d72b60262@xxxxxxxxxxx/
> will contain what you need.
Looks like we are going to need to full series (or at least until and
including patch 11) before this can get in. Gary, what tree are you
planning to merge the register projection series into? It would be nice
if we could do it in a way that makes it possible for this series to be
merged shortly after (either through `drm-rust-next`, or a merged signed
tag) for the next cycle.