Re: [PATCH 01/12] rust: io: add Region::try_subregion

From: Eliot Courtney

Date: Mon Aug 10 2026 - 02:32:34 EST


On Wed Aug 5, 2026 at 7:43 PM JST, Gary Guo wrote:
> On Wed Aug 5, 2026 at 6:44 AM BST, Eliot Courtney wrote:
>> Add a helper to get a subregion of an IO view fallibly.
>>
>> Signed-off-by: Eliot Courtney <ecourtney@xxxxxxxxxx>
>> ---
>> rust/kernel/io.rs | 31 ++++++++++++++++++++++++++++++-
>> 1 file changed, 30 insertions(+), 1 deletion(-)
>
> Looks like the case where you need this don't actually require a `Region`
> (dynamically sized type) but rather a fixed size window?
>
> In that case the next version of
> https://lore.kernel.org/rust-for-linux/20260721-typed_register-v1-0-452d72b60262@xxxxxxxxxxx/
> will contain what you need.
>
> Best,
> Gary

Thanks! I updated the code to use your v2 of that. To support the
runtime offset I ended up having to use OffsetLoc which you have as
#[doc(hidden)]. I will send the respin shortly.