Re: [PATCH v2 2/4] firmware: qcom: scm: use __free(qcom_tzmem) to simplify cleanup

From: Bartosz Golaszewski

Date: Mon Aug 10 2026 - 04:44:26 EST


On Wed, 5 Aug 2026 00:30:47 +0200, Bjorn Andersson <andersson@xxxxxxxxxx> said:
> On Fri, Jul 31, 2026 at 10:00:35AM +0200, Bartosz Golaszewski wrote:
>> Use the __free(qcom_tzmem) cleanup attribute (together with no_free_ptr()
>> whenever ownership is transferred) to replace open-coded
>> qcom_tzmem_free() calls and their associated goto labels.
>>
>> Reviewed-by: Konrad Dybcio <konrad.dybcio@xxxxxxxxxxxxxxxx>
>> Reviewed-by: Mukesh Ojha <mukesh.ojha@xxxxxxxxxxxxxxxx>
>> Signed-off-by: Bartosz Golaszewski <bartosz.golaszewski@xxxxxxxxxxxxxxxx>
>
> I tried to pick patch 1 and 2, but it doesn't compile. Please have a
> look.
>

Can you post the output? I rebased the series on top of current next and each
patch builds fine for me with arm64 defconfig.

Bart