Re: [PATCH net v3] gtp: serialize PDP context updates
From: Kuniyuki Iwashima
Date: Mon Aug 10 2026 - 22:47:12 EST
From: Qing Ming <a0yami@xxxxxxxxxxx>
Date: Tue, 11 Aug 2026 10:20:12 +0800
> PDP contexts can be deleted through GTP_CMD_DELPDP or while the GTP
> network device is being unregistered. The latter is serialized by RTNL,
> but the generic-netlink delete path only holds RCU.
>
> Running both paths concurrently can therefore make both paths delete the
> same PDP context. The issue was found through static analysis and
> reproduced on a KASAN-enabled kernel by a two-thread program
> racing GTP_CMD_DELPDP against RTM_DELLINK:
>
> Oops: general protection fault, probably for non-canonical address
> KASAN: maybe wild-memory-access in range
> [0xdead000000000120-0xdead000000000127]
> RIP: gtp_genl_del_pdp+0x1c1/0x420 [gtp]
> RBP: dead000000000122
>
> The second deletion dereferenced the poisoned hlist pprev pointer.
>
> Serialize PDP context updates with a mutex shared by gtp_pdp_add(),
> gtp_genl_del_pdp(), and gtp_dellink().
>
> Fixes: 459aa660eb1d ("gtp: add initial driver for datapath of GPRS Tunneling Protocol (GTP-U)")
> Assisted-by: Codex:gpt-5
> Signed-off-by: Qing Ming <a0yami@xxxxxxxxxxx>
> ---
> v3:
> - Rebase onto net/main.
>
> v2: https://lore.kernel.org/netdev/20260808124322.5800-1-a0yami@xxxxxxxxxxx/
> - Use a dedicated mutex instead of RTNL.
> - Protect PDP add, delete, and link teardown with the same mutex.
>
> drivers/net/gtp.c | 9 +++++++++
> 1 file changed, 9 insertions(+)
>
> diff --git a/drivers/net/gtp.c b/drivers/net/gtp.c
> index 9a12cc53da00..8ee516debeed 100644
> --- a/drivers/net/gtp.c
> +++ b/drivers/net/gtp.c
> @@ -12,6 +12,7 @@
> #define pr_fmt(fmt) KBUILD_MODNAME ": " fmt
>
> #include <linux/module.h>
> +#include <linux/mutex.h>
> #include <linux/skbuff.h>
> #include <linux/udp.h>
> #include <linux/rculist.h>
> @@ -108,6 +109,7 @@ struct gtp_net {
> };
>
> static u32 gtp_h_initval;
> +static DEFINE_MUTEX(gtp_pdp_lock);
>
> static struct genl_family gtp_genl_family;
>
> @@ -1555,9 +1557,11 @@ static void gtp_dellink(struct net_device *dev, struct list_head *head)
> struct pdp_ctx *pctx;
> int i;
>
> + mutex_lock(>p_pdp_lock);
> for (i = 0; i < gtp->hash_size; i++)
> hlist_for_each_entry_safe(pctx, next, >p->tid_hash[i], hlist_tid)
> pdp_context_delete(pctx);
> + mutex_unlock(>p_pdp_lock);
>
> list_del(>p->list);
> unregister_netdevice_queue(dev, head);
> @@ -1833,6 +1837,8 @@ static struct pdp_ctx *gtp_pdp_add(struct gtp_dev *gtp, struct sock *sk,
> __be32 ms_addr;
> int family;
>
> + guard(mutex)(>p_pdp_lock);
> +
Please use the plain mutex_lock() / mutex_unlock().
---8<---
$ cat Documentation/process/maintainer-netdev.rst
...
Using device-managed and cleanup.h constructs
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Netdev remains skeptical about promises of all "auto-cleanup" APIs,
including even ``devm_`` helpers, historically. They are not the preferred
style of implementation, merely an acceptable one.
Use of ``guard()`` is discouraged within any function longer than 20 lines,
``scoped_guard()`` is considered more readable. Using normal lock/unlock is
still (weakly) preferred.
---8<---