Re: [PATCH net-next] net/mlx5: SD, prefer sd_group_size from vport context

From: Simon Horman

Date: Tue Aug 11 2026 - 08:46:35 EST


On Mon, Aug 10, 2026 at 12:30:37PM +0300, Tariq Toukan wrote:
> From: Shay Drory <shayd@xxxxxxxxxx>
>
> Newer FW reports the SD group size directly in the NIC vport context
> via the sd_group_size field, gated by the sd_group_size capability.
> Switch sd_init() to source the group size from there and fall back to
> the MPIR-based host_buses query only when the cap is absent.
> sd_group_size might return 1 in some FW configuration. Add explicit
> check to disable SD creation in this case.
>
> While here, rename host_buses to group_size throughout sd.c to follow
> the new name on capable FW.
>
> issue: 4680618
> Signed-off-by: Shay Drory <shayd@xxxxxxxxxx>
> Reviewed-by: Moshe Shemesh <moshe@xxxxxxxxxx>
> Signed-off-by: Tariq Toukan <tariqt@xxxxxxxxxx>

Hi,

I'd appreciate it if you could take a look over the AI-generated review
of this patch at https://netdev-ai.bots.linux.dev/sashiko/#/patchset/20260810093037.3138197-1-tariqt%40nvidia.com

But my feeling is that this patch is good as-is.

Reviewed-by: Simon Horman <horms@xxxxxxxxxx>