[PATCH 0/2] acpi: add kernel option to skip binding drivers to certain devices
From: dmukhin
Date: Wed Aug 12 2026 - 23:09:58 EST
Mini series to allow fine-grained platform device ownership in
virtualized environment.
Patch 1: cleanup - replace an open-coded string with an existing symbol.
Patch 2: introduce the acpi.skip_ids= boot parameter.
Tested on: Linux 6.12.
Denis Mukhin (2):
acpi: Use METHOD_NAME__UID instead of open-coded _UID
acpi: bus: Introduce acpi.skip_ids= boot parameter
.../admin-guide/kernel-parameters.txt | 5 ++
drivers/acpi/acpi_processor.c | 2 +-
drivers/acpi/bus.c | 60 +++++++++++++++++--
3 files changed, 62 insertions(+), 5 deletions(-)
--
2.54.0