[PATCH v2] staging: media: atomisp: Use ARRAY_SIZE macro

From: Rishab Madhugiri

Date: Thu Aug 13 2026 - 03:56:37 EST


Clean up loop bound calculation by replacing sizeof(bds_factors) /
sizeof(struct bayer_ds_factor) with the ARRAY_SIZE() helper macro
to improve readability and maintainability.

v2: Move loop increment to the same line as the for statement as requested.

Signed-off-by: Rishab Madhugiri <rishab.madhugiri@xxxxxxxxx>
---
drivers/staging/media/atomisp/pci/atomisp_compat_css20.c | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)

diff --git a/drivers/staging/media/atomisp/pci/atomisp_compat_css20.c b/drivers/staging/media/atomisp/pci/atomisp_compat_css20.c
index 0ee52637e..e8734ca1a 100644
--- a/drivers/staging/media/atomisp/pci/atomisp_compat_css20.c
+++ b/drivers/staging/media/atomisp/pci/atomisp_compat_css20.c
@@ -2160,8 +2160,7 @@ static void __configure_video_pp_input(struct atomisp_sub_device *asd,
bayer_ds_out_res->width = effective_res->width;
bayer_ds_out_res->height = effective_res->height;

- for (i = 0; i < sizeof(bds_factors) / sizeof(struct bayer_ds_factor);
- i++) {
+ for (i = 0; i < ARRAY_SIZE(bds_factors); i++) {
if (effective_res->width >= out_width *
bds_factors[i].numerator / bds_factors[i].denominator &&
effective_res->height >= out_height *
--
2.43.0