Re: [PATCH 1/2] dmaengine: use dma_chan_name() helper to get per-channel device name
From: Logan Gunthorpe
Date: Thu Aug 13 2026 - 13:31:12 EST
On 2026-08-12 3:24 p.m., Frank.Li@xxxxxxxxxxx wrote:
> From: Frank Li <Frank.Li@xxxxxxx>
>
> Use the existing dma_chan_name() helper to obtain the per-channel device
> name instead of open-coding: dev_name(chan->dev->device) /
> dev_name(chan2dev())
>
> Simplify the code and improve consistency.
>
> No functional change intended.
>
> Signed-off-by: Frank Li <Frank.Li@xxxxxxx>
Makes sense to me.
Reviewed-by: Logan Gunthorpe <logang@xxxxxxxxxxxx>