Re: [PATCH 1/2] gpu: nova-core: gsp: retain the GSP-RM log buffers after unbind

From: John Hubbard

Date: Thu Aug 13 2026 - 15:31:46 EST


On 8/13/26 9:29 AM, Timur Tabi wrote:
> On Wed, 2026-08-12 at 15:41 -0700, John Hubbard wrote:
>> And so should nova! (Except for the strangely worded "keep_gsp_logging"
>> param name.) See below.
>
> The patch set that added that parameter to Nouveau was under review for months, and no one had
> any complaints about it until now. Regardless of whether it's "strange", I think it's important

I'm not keeping a close eye on the nouveau list.

> that both Nouveau and Nova use the same parameter for the same functionality, so Nova should
> also call it "keep_gsp_logging".


Completely disagree. There is no need for these disparate drivers to share
a name, especially given that a better name is available. I'm quite
unhappy with your continuing efforts to add artificial constraints
along the lines of "nova must match nouveau", tbh.

Nothing is stopping nouveau from adopting nova's names, if that is
desirable from their end.


thanks,
--
John Hubbard