Re: [PATCH] ring-buffer: Fixes for subbuf resizing
From: Vincent Donnefort
Date: Fri Aug 14 2026 - 04:31:19 EST
On Thu, Aug 13, 2026 at 09:52:30PM -0400, Steven Rostedt wrote:
> From: Vincent Donnefort <vdonnefort@xxxxxxxxxx>
>
> This series addresses multiple issues discovered with the dynamic ring
> buffer resizing.
>
> Signed-off-by: Vincent Donnefort <vdonnefort@xxxxxxxxxx>
> Signed-off-by: Steven Rostedt <rostedt@xxxxxxxxxxx>
> ---
>
> This is patches 1-5,7-9 of series: https://lore.kernel.org/all/20260813131152.3589632-1-vdonnefort@xxxxxxxxxx/
>
> I'm running them through my tests right now. But I wanted to see what
> Sashiko thinks of them as one big patch. In the series, Sashiko kept
> complaining about existing issues that were fixed later in the series.
> Sending this as one big patch will hopefully have it give better feedback.
And it actually does not look bad!
The only comment left was fixed in "ring-buffer: Make nr_pages unsigned int",
which from Steven's feedback must be renamed as we may want to keep nr_pages
unsigned long where possible.
>
> kernel/trace/ring_buffer.c | 268 ++++++++++++++++++++++---------------
> 1 file changed, 158 insertions(+), 110 deletions(-)
>
[...]