Re: [PATCH 6/6] mm/mglru: batch move folios to the second-oldest gen's LRU
From: Baoquan He
Date: Wed Aug 26 2026 - 05:34:58 EST
On 08/21/26 at 06:25pm, Barry Song (Xiaomi) wrote:
> Detect folios that need to move from the oldest generation to
> the second-oldest generation, and batch-move them together.
> This can significantly reduce the sys time of inc_min_seq(),
> especially when the other type is significantly behind the
> preferred type.
>
> Assisted-by: gemini:gemini-3.6-flash
> Signed-off-by: Barry Song (Xiaomi) <baohua@xxxxxxxxxx>
> ---
> mm/vmscan.c | 21 ++++++++++++++++++++-
> 1 file changed, 20 insertions(+), 1 deletion(-)
>
> diff --git a/mm/vmscan.c b/mm/vmscan.c
> index 2fd82b2ca4d1..996b48344ed0 100644
> --- a/mm/vmscan.c
> +++ b/mm/vmscan.c
> @@ -3923,6 +3923,19 @@ static void clear_mm_walk(void)
> kfree(walk);
> }
>
> +static inline void flush_lru_batch(struct list_head *head, struct list_head **batch_end,
> + struct list_head *dst)
> +{
> + LIST_HEAD(movable);
> +
> + if (!*batch_end)
> + return;
> +
> + list_cut_position(&movable, head, *batch_end);
> + list_splice_tail_init(&movable, dst);
> + *batch_end = NULL;
> +}
> +
> static bool inc_min_seq(struct lruvec *lruvec, int type, int swappiness)
> {
> int zone;
> @@ -3942,9 +3955,11 @@ static bool inc_min_seq(struct lruvec *lruvec, int type, int swappiness)
>
> /* prevent cold/hot inversion if the type is evictable */
> for (zone = 0; zone < MAX_NR_ZONES; zone++) {
> + struct list_head *target_list = &lrugen->folios[target_gen][type][zone];
> struct list_head *head = &lrugen->folios[old_gen][type][zone];
> unsigned long protected[MAX_NR_TIERS] = {}, delta = 0;
> struct list_head *pos = head->next;
> + struct list_head *batch_end = NULL;
>
> while (pos != head) {
> struct folio *folio = list_entry(pos, struct folio, lru);
> @@ -3963,7 +3978,8 @@ static bool inc_min_seq(struct lruvec *lruvec, int type, int swappiness)
> new_gen = __folio_inc_gen(folio, old_gen, &gen_increased);
> if (gen_increased) {
> delta += nr_pages;
> - list_move_tail(&folio->lru, &lrugen->folios[new_gen][type][zone]);
> + batch_end = &folio->lru;
> +
> /* don't count the workingset being lazily promoted */
> if (refs + workingset != BIT(LRU_REFS_WIDTH) + 1) {
> int tier = lru_tier_from_refs(refs, workingset);
> @@ -3971,11 +3987,14 @@ static bool inc_min_seq(struct lruvec *lruvec, int type, int swappiness)
> protected[tier] += nr_pages;
> }
> } else {
> + flush_lru_batch(head, &batch_end, target_list);
How about this? then you only have "struct list_head *batch_end" in 2nd
parameter. And explicit resetting batch_end makes code more readable?
flush_lru_batch(head, batch_end, target_list);
batch_end = NULL;
Anyway, personal preference, not strong opinion.
Other than the nit,
Reviewed-by: Baoquan He <baoquan.he@xxxxxxxxx>
> list_move(&folio->lru, &lrugen->folios[new_gen][type][zone]);
> }
> if (!--remaining)
> break;
> }
> + flush_lru_batch(head, &batch_end, target_list);
> +
> WRITE_ONCE(lrugen->nr_pages[old_gen][type][zone],
> lrugen->nr_pages[old_gen][type][zone] - delta);
> WRITE_ONCE(lrugen->nr_pages[target_gen][type][zone],
> --
> 2.34.1
>