Re: [PATCH 5/6] userfaultfd: decouple fault reason from VMA flags
From: David Hildenbrand (Arm)
Date: Thu Aug 27 2026 - 05:21:38 EST
On 8/27/26 11:09, Mike Rapoport wrote:
> On Thu, Aug 27, 2026 at 10:10:24AM +0200, David Hildenbrand (Arm) wrote:
>> On 8/27/26 09:49, Mike Rapoport wrote:
>>>
>>> userfault_reason sounds better to me.
>>>
>>> It describes what kind of user fault we are handling and the 'fd' part has
>>> nothing to do with it.
>>> We do use uffd as a short name for the subsystem, but still most if not all
>>> userfaultfd "external" APIs use userfault_ prefix.
>>>
>>> uf_ was an attempt to make it wee shorter :)
>>
>> Yeah, I got that; while uffd is a known acronym, the uf_ not so much (and also I
>> wouldn't suggest it to become a thing, lol :) )
>>
>> I've been wondering for a while whether it really should be called
>>
>> handle_userfault()
>>
>> And not instead
>>
>> handle_userfaultfd()
>
> The 'fd' part here sounds really weird :)
>
>> Or maybe even better
>>
>> handle_uffd_fault()
>
> That's somehow tautological, but maybe using uffd_ as prefix would make it
> a "subsystem namespace", so tautology won't be as blunt:
>
> uffd_handle_fault()
>
>> And then have
>>
>> uffd_fault_reason
>
> Could work, yes. No strong feelings between this one and userfault_reason.
I lean towards just calling stuff uffd consistently might be cleanest.
--
Cheers,
David