Re: [PATCH 1/3] mm/mglru: improve readability of isolate_folios()
From: Baoquan He
Date: Thu Aug 27 2026 - 23:15:47 EST
On 08/20/26 at 12:56pm, Barry Song (Xiaomi) wrote:
> From: Ridong Chen <chenridong@xxxxxxxxxx>
>
> The for_each_evictable_type() loop in isolate_folios()
> is misleading: it does not actually iterate over each
> evictable type. Instead, get_type_to_scan() selects the
> type to scan, while the iterator `i` merely bounds the
> number of attempts.
>
> Make the fallback behavior explicit in the code and remove the
> opaque for_each_evictable_type(i, swappiness).
>
> Signed-off-by: Ridong Chen <chenridong@xxxxxxxxxx>
> Co-developed-by: Barry Song (Xiaomi) <baohua@xxxxxxxxxx>
> Signed-off-by: Barry Song (Xiaomi) <baohua@xxxxxxxxxx>
> ---
> mm/vmscan.c | 46 ++++++++++++++++++++++++++--------------------
> 1 file changed, 26 insertions(+), 20 deletions(-)
The subject doens't reflect the truth. This patch changes the behaviour,
but not improve readability of isolate_folios() only.
I also noticed the confusion of isolate_folios() implementation, and made
a patch to only change the local variable and added code comment to
explain it in my local branch. Surely refactorying is also good.
+ * Scan at most one type per evictable type (anon/file), starting with
+ * the type get_type_to_scan() picked as statistically colder.
+ *
+ * After a scan:
+ * - isolated > 0: got folios, record the type and return.
+ * - scanned == 0: the type is empty; fall back to the other type.
+ * - otherwise: the type has folios but all were hot (or lost an
+ * isolate race); retry the same type rather than
+ * switch, so positive_ctrl_err()'s refault
+ * statistics stay unbiased.
+ */
While in Ridong's patch, the 3rd case disappeared. It doesn't rescan with
the original type as the old code is doing, but return directly.
>
> diff --git a/mm/vmscan.c b/mm/vmscan.c
> index c1404a59523d..d5cc30b667ad 100644
> --- a/mm/vmscan.c
> +++ b/mm/vmscan.c
> @@ -4833,35 +4833,41 @@ static int get_type_to_scan(struct lruvec *lruvec, int swappiness)
> return positive_ctrl_err(&sp, &pv);
> }
>
> +static inline bool is_single_type_reclaim(int swappiness)
> +{
> + return swappiness == MIN_SWAPPINESS ||
> + swappiness == SWAPPINESS_ANON_ONLY;
> +}
> +
> static int isolate_folios(unsigned long nr_to_scan, struct lruvec *lruvec,
> struct scan_control *sc, int swappiness,
> struct list_head *list, int *isolated,
> int *isolate_type, int *isolate_scanned)
> {
> - int i;
> - int total_scanned = 0;
> + bool type_fallback_allowed = !is_single_type_reclaim(swappiness);
> int type = get_type_to_scan(lruvec, swappiness);
> + int total_scanned = 0, scanned, tier;
>
> - for_each_evictable_type(i, swappiness) {
> - int scanned;
> - int tier = get_tier_idx(lruvec, type);
> +retry:
> + tier = get_tier_idx(lruvec, type);
> + scanned = scan_folios(nr_to_scan, lruvec, sc,
> + type, tier, list, isolated);
>
> - scanned = scan_folios(nr_to_scan, lruvec, sc,
> - type, tier, list, isolated);
> + total_scanned += scanned;
> + if (*isolated) {
> + *isolate_type = type;
> + *isolate_scanned = scanned;
> + return total_scanned;
> + }
>
> - total_scanned += scanned;
> - if (*isolated) {
> - *isolate_type = type;
> - *isolate_scanned = scanned;
> - break;
> - }
> - /*
> - * If scanned > 0 and isolated == 0, avoid falling back to the
> - * other type, as this type remains sufficient. Falling back
> - * too readily can disrupt the positive_ctrl_err() bias.
> - */
> - if (!scanned)
> - type = !type;
> + /*
> + * We are running out of the current reclaim type. Fall back to
> + * the other type if allowed.
> + */
> + if (!scanned && type_fallback_allowed) {
> + type = !type;
> + type_fallback_allowed = false;
> + goto retry;
> }
>
> return total_scanned;
> --
> 2.34.1
>