RE: [PATCH rtw-next v7 1/3] wifi: rtw88: rtw8822c: Use bitfield macros for DAC IQ sampling

From: Ping-Ke Shih

Date: Fri Aug 28 2026 - 04:23:44 EST


Arsenii Pashchenko <ulijg308@xxxxxxxxx> wrote:
> Define proper GENMASK constants for the In-phase (I) and Quadrature
> (Q) components of the DAC IQ data register in the header file.
> Replace manual bit shifting, masking, and rtw_read32_mask() with
> standard rtw_read32() and the FIELD_GET() macro to improve code
> readability.
>
> Signed-off-by: Arsenii Pashchenko <ulijg308@xxxxxxxxx>

I suppose you don't have change from v6 to v7, so just take
my acked-by?

Acked-by: Ping-Ke Shih <pkshih@xxxxxxxxxxx>