Re: [PATCH] crypto: amcc: pass core_dev to request_irq

From: Herbert Xu

Date: Fri Sep 04 2026 - 06:00:09 EST


On Wed, Aug 12, 2026 at 12:15:55PM -0700, Rosen Penev wrote:
> Instead of using a get_drvdata function to get the proper struct, just
> pass the proper thing directly.
>
> Assisted-by: opencode:big-pickle
> Signed-off-by: Rosen Penev <rosenp@xxxxxxxxx>
> ---
> drivers/crypto/amcc/crypto4xx_core.c | 9 ++++-----
> 1 file changed, 4 insertions(+), 5 deletions(-)

Patch applied. Thanks.
--
Email: Herbert Xu <herbert@xxxxxxxxxxxxxxxxxxx>
Home Page: http://gondor.apana.org.au/~herbert/
PGP Key: http://gondor.apana.org.au/~herbert/pubkey.txt