[PATCH 00/12] mm/collapse: separate a collapse from its callers
From: Kiryl Shutsemau
Date: Fri Sep 04 2026 - 12:50:35 EST
From: "Kiryl Shutsemau (Meta)" <kas@xxxxxxxxxx>
[ This is the first of the cleanups I said I would front-load ]
There is no line between the collapse engine and the callers that ask for
a collapse. khugepaged.c holds both, and they reach into each other.
- Sixteen tests through the collapse path read cc->is_khugepaged to work
out what they are allowed to do, when every one of those decisions was
made by the caller before it asked.
- collapse_single_pmd() does both halves of a collapse behind one call and
drops mmap_lock somewhere in the middle. Which of its paths dropped it
is not something a caller can see, so it hands back a bool and the
caller keeps track.
- MADV_COLLAPSE's implementation -- the walk over the user's range, the
per-PMD loop, the errno translation -- sits in khugepaged.c, which is
the daemon's file.
So: draw the line. State what a caller allows in a policy, split the call
in two with the lock as the boundary, and move the syscall to madvise.c.
What the engine offers is then four calls, with the lock state written
down against each, and a policy the caller fills for itself:
collapse_control_init(cc) once, before the first table
collapse_policy_*(&cc->policy) what this caller allows
collapse_scan_pmd(vma, addr, ...) per table, under mmap_lock
collapse_run_pmd(mm, addr, cc) when a scan found work, no mmap_lock
collapse_control_release(cc) once, when done
The engine stays in khugepaged.c for now; what changes is that it has an
interface, and that neither half has to ask about the other. madvise.c
gains the operation it should have had all along.
Patches
=======
The first three stand alone and can be taken separately:
1 drop the mmgrab() MADV_COLLAPSE has held since 7d8faaf15545
2 count collapses in khugepaged's own walk, where the daemon's
bookkeeping belongs
3 rename cc->mthp_present_ptes to eligible_ptes, which is what a set
bit means
Then the interface, in order:
4 add collapse.h, and move enum scan_result, struct collapse_control
and the two constants into it
5 struct collapse_policy, filled by the caller; the is_khugepaged
tests become field reads, and the flag goes
6 drop collapse_possible(), a wrapper that only turns a mask into a bool
7 collapse_control_init_scan() is a per-table reset, so name it
collapse_scan_reset()
8 give the scan and the collapse a function each: collapse_scan_pmd()
and collapse_run_pmd()
9 open-code the entry point that joined them, so each caller owns the
lock across the boundary and the bool goes
10 work out the orders a VMA allows once per VMA, not once per table
11 declare the four calls in collapse.h, with the lock rules
12 MADV_COLLAPSE moves to madvise.c
Behaviour
=========
Nothing here changes what gets collapsed. Three things a reader should
not have to find in the diff:
- Patch 5: khugepaged fills its policy once per scan pass, so the
max_ptes_* limits and the defrag setting behind the allocation mask are
sampled once per pass rather than once per table. A table scanned early
in a pass and one scanned late are then judged alike, where before a
knob written mid-pass split them.
- Patch 8: mm_khugepaged_scan_pmd fires before mm_collapse_huge_page
rather than after it, the scan having returned before the collapse
runs. Its status field already reads SCAN_SUCCEED for an accepted
table, so nothing changes there; what the collapse then made of the
table is mm_collapse_huge_page's to report, per order.
- Patch 10: which orders a table is scanned for is sampled once per VMA
rather than once per table. It cannot widen what a collapse does --
the order is tested again under the lock the collapse retakes.
The lock itself is given up and taken again at exactly the points it was
before; the only difference is that the caller is the one doing it.
selftests/mm khugepaged passes on x86-64 with a KASAN, lockdep and
DEBUG_VM config, and every patch builds, CONFIG_TRANSPARENT_HUGEPAGE=n
included.
Kiryl Shutsemau (Meta) (12):
mm/khugepaged: drop redundant mm_struct pin in madvise_collapse()
mm/khugepaged: count collapses where khugepaged makes them
mm/khugepaged: rename mthp_present_ptes bitmap to eligible_ptes
mm/collapse: add collapse.h for the collapse interface
mm/collapse: state what a collapse may do in the policy
mm/collapse: drop the collapse_possible() wrapper
mm/collapse: name the per-table scan reset for what it resets
mm/collapse: separate scanning a PTE table from collapsing it
mm/collapse: open-code collapse_single_pmd() in its two callers
mm/collapse: work out the orders a VMA allows once per VMA
mm/collapse: declare the collapse interface in collapse.h
mm/collapse: implement MADV_COLLAPSE in madvise.c
MAINTAINERS | 1 +
include/linux/huge_mm.h | 9 -
mm/collapse.h | 163 ++++++++++++++
mm/khugepaged.c | 485 ++++++++++++++--------------------------
mm/madvise.c | 169 +++++++++++++-
5 files changed, 497 insertions(+), 330 deletions(-)
create mode 100644 mm/collapse.h
base-commit: e3fc12b08aadde9cec7b3799ac0e0c9a1aa245c4
--
2.54.0