Re: [PATCH v2 7/8] lib: convert process iterator to for_each_process_rculock

From: Lorenzo Stoakes (ARM)

Date: Mon Sep 07 2026 - 08:32:05 EST


On Mon, Sep 07, 2026 at 04:13:33PM +0800, Ye Liu wrote:
> From: Ye Liu <liuye@xxxxxxxxxx>
>
> Replace the manual rcu_read_lock()/rcu_read_unlock() pair combined
> with for_each_process() loop in lib/ with for_each_process_rculock(),
> which scopes the RCU read lock to the loop body via scoped_guard(rcu).
>
> No functional change.
>
> Signed-off-by: Ye Liu <liuye@xxxxxxxxxx>
> Acked-by: Michal Hocko <mhocko@xxxxxxxx>

LGTM so:

Reviewed-by: Lorenzo Stoakes (ARM) <ljs@xxxxxxxxxx>

> ---
> Changes in v2:
> - Rename *_rcu to *_rculock
> lib/is_single_threaded.c | 5 +----
> 1 file changed, 1 insertion(+), 4 deletions(-)
>
> diff --git a/lib/is_single_threaded.c b/lib/is_single_threaded.c
> index 8c98b20bfc41..4e7fe85454ab 100644
> --- a/lib/is_single_threaded.c
> +++ b/lib/is_single_threaded.c
> @@ -26,8 +26,7 @@ bool current_is_single_threaded(void)
> return true;
>
> ret = false;
> - rcu_read_lock();
> - for_each_process(p) {
> + for_each_process_rculock(p) {
> if (unlikely(p->flags & PF_KTHREAD))
> continue;
> if (unlikely(p == task->group_leader))
> @@ -48,7 +47,5 @@ bool current_is_single_threaded(void)
> }
> ret = true;
> found:
> - rcu_read_unlock();
> -
> return ret;
> }
> --
> 2.25.1
>

--
Cheers, Lorenzo