Re: [PATCH] selftests/powerpc: use MAP_FAILED instead of (void *)-1 in tm-signal-context-force-tm
From: Venkat
Date: Wed Sep 09 2026 - 09:42:02 EST
> On 22 Jul 2026, at 8:04 AM, longlong yan <yanlonglong@xxxxxxxxxx> wrote:
>
> mmap() is documented to return MAP_FAILED on error, but
> tm-signal-context-force-tm.c compares the return value against
> (void *)-1. Replace these with the standard MAP_FAILED macro for
> better readability and type safety.
>
> Signed-off-by: longlong yan <yanlonglong@xxxxxxxxxx>
> ---
Tested this patch, by applying on top of mainline.
Tested-by: Venkat Rao Bagalkote <venkat88@xxxxxxxxxxxxx>
# timeout set to 0
# selftests: powerpc/tm: tm-signal-context-force-tm
# test: tm_signal_context_force_tm
# tags: git_version:v7.3-rc2-28-g5572a2d442d5
# success: tm_signal_context_force_tm
ok 18 selftests: powerpc/tm: tm-signal-context-force-tm
Regards,
Venkat.
> .../testing/selftests/powerpc/tm/tm-signal-context-force-tm.c | 4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/tools/testing/selftests/powerpc/tm/tm-signal-context-force-tm.c b/tools/testing/selftests/powerpc/tm/tm-signal-context-force-tm.c
> index 0a4bc479ae39..5dc0f12f467d 100644
> --- a/tools/testing/selftests/powerpc/tm/tm-signal-context-force-tm.c
> +++ b/tools/testing/selftests/powerpc/tm/tm-signal-context-force-tm.c
> @@ -60,7 +60,7 @@ void usr_signal_handler(int signo, siginfo_t *si, void *uc)
> ucp->uc_link = mmap(NULL, sizeof(ucontext_t),
> PROT_READ | PROT_WRITE,
> MAP_PRIVATE | MAP_ANONYMOUS, 0, 0);
> - if (ucp->uc_link == (void *)-1) {
> + if (ucp->uc_link == MAP_FAILED) {
> perror("Mmap failed");
> exit(-1);
> }
> @@ -129,7 +129,7 @@ void tm_trap_test(void)
> ss.ss_size = SIGSTKSZ;
> ss.ss_flags = 0;
>
> - if (ss.ss_sp == (void *)-1) {
> + if (ss.ss_sp == MAP_FAILED) {
> perror("mmap error\n");
> exit(-1);
> }
> --
> 2.43.0
>