Re: [PATCH v4 05/17] mm/huge_memory: rename __split_unmapped_folio() to __split_frozen_folio()

From: David Hildenbrand (Arm)

Date: Wed Sep 09 2026 - 14:36:31 EST


On 9/7/26 20:12, Kairui Song via B4 Relay wrote:
> From: Kairui Song <kasong@xxxxxxxxxxx>
>
> The helper splits a folio whose refcount is frozen: the frozen refcount
> is the state it relies on, while unmapping is arranged by the caller
> beforehand. The old name caused confusion and people may try to call the
> helper on non-frozen folios.
>
> Also add a VM_WARN_ON_ONCE_FOLIO(folio_mapped(folio)) to self document
> that frozen implies unmapped.
>
> Suggested-by: Zi Yan <ziy@xxxxxxxxxx>
> Reviewed-by: Zi Yan <ziy@xxxxxxxxxx>
> Reviewed-by: Yeoreum Yun <yeoreum.yun@xxxxxxx>
> Reviewed-by: Kiryl Shutsemau (Meta) <kas@xxxxxxxxxx>
> Signed-off-by: Kairui Song <kasong@xxxxxxxxxxx>
> ---
Acked-by: David Hildenbrand (Arm) <david@xxxxxxxxxx>

--
Cheers,

David