Re: [PATCH] scsi: zorro7xx: Use individual zorro_driver_data structures

From: Martin K. Petersen (Oracle)

Date: Wed Sep 09 2026 - 21:49:07 EST



Geert,

> Using an array of zorro_driver_data objects and referring to its
> elements by index obfuscates the code and is error-prone.
>
> Improve readability and reduce code size by replacing the array (which
> includes an unneeded sentinel) by individual zorro_driver_data objects.

Applied to 7.4/scsi-staging, thanks!

--
Martin K. Petersen