[PATCH 00/13] PCI: brcmstb: Stop using chip numbers for conditions
From: Jim Quinlan
Date: Fri Sep 11 2026 - 19:38:28 EST
Much of the brcmstb PCIe driver code does (essentially) this:
if (pcie->chip == 0x1234 || pcie->chip == 0x5678) {
/* ... */
}
when it should instead do this:
if (behavior_xyz(pcie)) {
/* ... */
}
This series does the above. In addition, some other minor improvements are
added in the hopes of making the code more readable.
Jim Quinlan (13):
PCI: brcmstb: Remove redundant const specifier for struct fields
PCI: brcmstb: Use flags u32 instead of bools
PCI: brcmstb: Add Broadcom quirks macro
PCI: brcmstb: Declare and assign quirk OB_WIN_32BIT_ADDR
PCI: brcmstb: Declare and assign quirk OB_WIN_MAXSZ_128MB
PCI: brcmstb: Declare and assign flag IS_BMIPS
PCI: brcmstb: Declare and assign quirk 32BIT_PCI_OPS
PCI: brcmstb: Declare and assign quirk NO_RGR1_TIMER
PCI: brcmstb: Declare and assign quirk EARLY_PERST_ASSERT
PCI: brcmstb: Declare and assign quirk PERST_PCIE_REV_CUTOFF
PCI: brcmstb: Put max_burst_size setting in cfg_data
PCI: brcmstb: Use order-0 indexing for inbound BAR window array
PCI: brcmstb: Split up complicated function into two variants
drivers/pci/controller/pcie-brcmstb.c | 267 +++++++++++++++-----------
1 file changed, 158 insertions(+), 109 deletions(-)
base-commit: bc35965f6940a9bf834d54187b6088b8eb09206d
--
2.34.1