Re: [RESEND v7 01/29] mm: rename pmd_to_softleaf_folio() to pmd_softleaf_to_folio()
From: Barry Song
Date: Mon Sep 14 2026 - 17:18:18 EST
On Mon, Sep 14, 2026 at 8:30 PM Usama Arif <usama.arif@xxxxxxxxx> wrote:
>
> pmd_to_softleaf_folio() reads as if it converted a PMD into a folio. What
> it does is decode the softleaf entry stored in the PMD and return the
> folio that entry references - the direction softleaf_to_folio() already
> spells out.
>
> No functional change intended.
>
> Suggested-by: Dev Jain <dev.jain@xxxxxxx>
> Signed-off-by: Usama Arif <usama.arif@xxxxxxxxx>
> Acked-by: David Hildenbrand (Arm) <david@xxxxxxxxxx>
> Reviewed-by: Lorenzo Stoakes (ARM) <ljs@xxxxxxxxxx>
> Reviewed-by: Zi Yan <ziy@xxxxxxxxxx>
> Acked-by: Kiryl Shutsemau (Meta) <kas@xxxxxxxxxx>
> ---
LGMT,
Reviewed-by: Barry Song <baohua@xxxxxxxxxx>