Re: [PATCH v6 00/11] Refactor Microchip MCP47FEB02 I2C driver in separate modules to add support for MCP48FEB02 SPI driver
From: Andy Shevchenko
Date: Wed Sep 16 2026 - 11:54:33 EST
On Wed, Sep 16, 2026 at 05:16:26PM +0300, Ariana Lazar wrote:
> Refactor I2C driver implementation into separate modules in order to add
> support for SPI MCP48FxBy1/2/4/8 DAC family on top of the I2C
> implementation. The I2C and SPI devices have the same memory map and
> supported functionalities.
>
> Signed-off-by: Ariana Lazar <ariana.lazar@xxxxxxxxxxxxx>
> ---
> Changes in v6:
> - use field_get() in Gain, Vref and Power-Down registers channel formulas
> - rebase from 7.2 to 7.3-rc1
> - add fixes tags and Cc stable in the commit messages
> - add numeric constants in front of time defines for better readability
> - replaced dev_err() with dev_warn_probe() for missing label
> - if match data is not found at probe, return -ENODATA and a suitable
> error message
> - Link to v5: https://lore.kernel.org/r/20260909-mcp47feb02_refactor-v5-0-8b67bcab93d1@xxxxxxxxxxxxx
My main comment against this version is the usage of Reported-by + Closes +
Fixes versus Suggested-by. Note, some of the changes doesn't look like a fix,
such as a typo in the comment, I dunno if Reported + Closes (no Fixes) is
legitimate approach there.
--
With Best Regards,
Andy Shevchenko