Re: [PATCH v7 3/3] hwspinlock: add low level debug capabilities

From: Geert Uytterhoeven

Date: Thu Sep 17 2026 - 04:13:47 EST


Hi Wolfram,

On Wed, 16 Sept 2026 at 23:44, Wolfram Sang
<wsa+renesas@xxxxxxxxxxxxxxxxxxxx> wrote:
> > > to request, free, lock, unlock, and test hwspinlocks. Because this is a
> > > potentially dangerous interface, it can only be enabled via source code.
> >
> > ... code,
> >
> > > Similar to writeable attributes for clocks where this idea stems from.
> >
> > similar ...
>
> You mean I should merge the two sentences into one?

Yes, as the second "sentence" does not have a verb.

> > > +static void hwspin_lock_low_level_debug_init(struct dentry *rootdir)
> > > +{
> > > + debugfs_create_file("request", 0200, rootdir, NULL, &fops_request);
> > > + debugfs_create_file("free", 0200, rootdir, NULL, &fops_free);
> > > + debugfs_create_file("lock", 0200, rootdir, NULL, &fops_trylock_raw);
> > > + debugfs_create_file("unlock", 0200, rootdir, NULL, &fops_unlock_raw);
> > > + debugfs_create_file("test_lock", 0200, rootdir, NULL, &fops_test);
> >
> > Perhaps just "test"?
>
> Hmm, too generic for my taste. In fact, I think I should maybe rename it
> to "test_single_lock" to make it more precise...

"test_single"? All others don't have "lock" in their name.

Gr{oetje,eeting}s,

Geert

--
Geert Uytterhoeven -- There's lots of Linux beyond ia32 -- geert@xxxxxxxxxxxxxx

In personal conversations with technical people, I call myself a hacker. But
when I'm talking to journalists I just say "programmer" or something like that.
-- Linus Torvalds