Re: [PATCH net-next v2 1/4] net: macb: Rename MACB_CAPS_QBV to MACB_CAPS_TC

From: Théo Lebrun

Date: Thu Sep 17 2026 - 05:43:49 EST


Hello Vineeth,

On Wed Sep 9, 2026 at 4:20 PM CEST, Vineeth Karumanchi wrote:
> The MACB_CAPS_QBV capability flag was originally introduced to
> gate TAPRIO/QBV support. However, GEM IP versions that support
> QBV also implement multiple TSN clauses.
>
> Replace this with a generic capability flag that can be reused
> by other TSN features. Rename MACB_CAPS_QBV to MACB_CAPS_TC to
> better reflect its role as a general traffic-class offload capability.
>
> The supported TSN clauses are handled through macb_setup_tc().
>
> Signed-off-by: Vineeth Karumanchi <vineeth.karumanchi@xxxxxxx>

As you pointed out in the past we cannot runtime detect because DCFG1
changes its bitfield layout across IPs... That could be useful info in
the commit message.

Reviewed-by: Théo Lebrun <theo.lebrun@xxxxxxxxxxx>

Thanks,

--
Théo Lebrun, Bootlin
Embedded Linux and Kernel engineering
https://bootlin.com