Re: [PATCH v13 04/12] spmi: Remove unneeded goto in spmi_device_add() error path
From: Abel Vesa
Date: Thu Sep 17 2026 - 12:04:48 EST
On 26-07-21 11:36:18, AngeloGioacchino Del Regno wrote:
> If any error happens during device_add() just return inside of the
> conditional, as the goto path doesn't do anything else if not just
> returning.
>
> While at it, to improve readability, also change this function to
> explicitly return 0 (for success) at the end.
>
> Acked-by: Stephen Boyd <sboyd@xxxxxxxxxx>
> Reviewed-by: Andy Shevchenko <andriy.shevchenko@xxxxxxxxx>
> Signed-off-by: AngeloGioacchino Del Regno <angelogioacchino.delregno@xxxxxxxxxxxxx>
Reviewed-by: Abel Vesa <abel.vesa@xxxxxxxxxxxxxxxx>