Re: [PATCH v2] mm/slub: make the case handling in __slab_free() easier to follow

From: Harry Yoo (Meta)

Date: Mon Sep 21 2026 - 11:19:01 EST


On Mon, 21 Sep 2026 20:43:22 +0800, Hao Li wrote:
> There are 8 possible transitions in __slab_free():
>
> a. partial->partial, offlist
> b. partial->partial, onlist
> c. partial->empty, offlist
> d. partial->empty, onlist, exceeding min_partial
> e. partial->empty, onlist, not exceeding min_partial
> f. full->empty, exceeding min_partial
> g. full->empty, not exceeding min_partial
> h. full->partial
>
> [...]

Applied to mm/slab.git slab/for-next, thanks!

[1/1] mm/slub: make the case handling in __slab_free() easier to follow
commit: 6932405b8154dd996b892a8a444a5543bb2bc35c

--
Cheers,
Harry / Hyeonggon