Re: [PATCH v2 2/2] mm/page_alloc: refactor build_node_zonelist() out of build_zonelists()
From: Zi Yan
Date: Mon Sep 21 2026 - 12:27:12 EST
On 20 Sep 2026, at 23:33, Gregory Price wrote:
> On Sun, Sep 20, 2026 at 10:53:13PM -0400, Zi Yan wrote:
>>>> +static void build_node_zonelist(pg_data_t *pgdat, const nodemask_t *candidates,
>>>> + int zlidx)
>>
>> Is build_numa_aware_zonelist() a better name? Since the old comment said
>> "NUMA-aware ording of nodes" and the code uses find_next_best_node_in().
>>
>
> I think that's a vestige of older version having different ordering
> options. Now the zonelists are always numa aware (except for
> !CONFIG_NUMA, which... duh).
Yeah, I am OK with the current name to avoid confusion on !CONFIG_NUMA.
>
> Anyway numa-aware is implied by "node" in the name.
>
> But I don't have strong feelings about the name either way.
Best Regards,
Yan, Zi