Re: [PATCH v3 3/4] kho: rename KHO scratch to KHO bootmem

From: sashiko-bot

Date: Tue Sep 22 2026 - 00:22:02 EST


> From: "Pratyush Yadav (Google)" <pratyush@xxxxxxxxxx>
>
> The term "KHO scratch" is vague and overloaded.
>
> For one, it does not accurately describe what the memory is for. From
> KHO's perspective, it is memory passed by the previous kernel that is
> guaranteed to have no allocations and hence it is safe to allocate from.
>
> For another, the term is overloaded. KHO also knows to discover other
> ranges of memory that don't have any preservations and are safe to
> allocate from. This is done by kho_extend_scratch(). These areas, while
> called "scratch", are completely different from the chunk of memory
> passed by the previous kernel for early boot allocations.
>
> Rename "KHO scratch" to "KHO boot memory", or "KHO bootmem" in short.
> Update all function names, variable names, comments, and documentation
> to use this.
>
> Call the discovered areas "noprsrv", matching what memblock would see
> them as. Rename kho_extend_scratch() to reflect this.
>
> This patch largely has no functional changes. The only functional
> changes are renames of debugfs files from "scratch_phys" and
> "scratch_len" to "bootmem_phys" and "bootmem_len" respectively.
>
> Signed-off-by: Pratyush Yadav (Google) <pratyush@xxxxxxxxxx>

Sashiko has reviewed this patch and found no issues. It looks great!

--
Sashiko AI review · https://sashiko.dev/#/patchset/20260922041321.233986-1-pratyush@xxxxxxxxxx?part=3