Re: [PATCH v3 19/19] drm/bridge: analogix_dp: don't create a panel_bridge

From: Damon Ding

Date: Tue Sep 22 2026 - 05:20:54 EST


On 9/22/2026 4:07 PM, Luca Ceresoli wrote:
Hello Damon,

On Mon Sep 21, 2026 at 8:34 AM CEST, Damon Ding wrote:
On 9/21/2026 11:07 AM, Damon Ding wrote:
Hi Luca,

On 9/16/2026 9:45 PM, Luca Ceresoli wrote:
Now a panel_bridge is automatically created for every drm_panel and the
panel-bridge API is just a deprecated wrapper to access it.

Update and simplify the code by just getting a reference to the
already-existing bridge using of_drm_get_bridge_by_endpoint().

As of_drm_get_bridge_by_endpoint() returns a refcounted bridge, take care
of putting the bridge reference. This is not easily done in the remove
path
due to the different probe paths of the user drivers, so add a devm
action
to ensure the reference is put only when it was taken.

Assisted-by: opencode:deepseek-v4-flash-0731
Signed-off-by: Luca Ceresoli <luca.ceresoli@xxxxxxxxxxx>
---
  drivers/gpu/drm/bridge/analogix/Kconfig            |  1 -
  drivers/gpu/drm/bridge/analogix/analogix_dp_core.c | 40 ++++++++++++
+---------
  drivers/gpu/drm/exynos/exynos_dp.c                 | 36 +
+-----------------
  drivers/gpu/drm/rockchip/analogix_dp-rockchip.c    |  9 -----
  include/drm/bridge/analogix_dp.h                   |  1 -
  5 files changed, 25 insertions(+), 62 deletions(-)


[snip]

@@ -488,14 +487,6 @@ static void rockchip_dp_remove(struct
platform_device *pdev)
  {
      struct rockchip_dp_device *dp = platform_get_drvdata(pdev);

The above unused &rockchip_dp_device could be also remved.

Ah, indeed!

I guess I can keep your review tags if applying this patch with only this
line removed. Correct?


Yeah, sure!

Best regards,
Damon