Re: [PATCH] perf jevents: Rename OMR offcore_rsp attribute to offmodule_rsp

From: Ian Rogers

Date: Wed Sep 23 2026 - 01:22:21 EST


On Tue, Sep 22, 2026 at 7:02 PM Dapeng Mi <dapeng1.mi@xxxxxxxxxxxxxxx> wrote:
>
> The kernel renamed the OMR data attribute from offcore_rsp to
> offmodule_rsp to avoid confusion and keep the naming consistent.
>
> So update the perf jevents msrmap accordingly.
>
> Link: https://lore.kernel.org/all/20260917015234.981153-12-dapeng1.mi@xxxxxxxxxxxxxxx/
> Link: https://lore.kernel.org/all/20260917015234.981153-13-dapeng1.mi@xxxxxxxxxxxxxxx/
> Signed-off-by: Dapeng Mi <dapeng1.mi@xxxxxxxxxxxxxxx>

Reviewed-by: Ian Rogers <irogers@xxxxxxxxxx>

Thanks,
Ian

> ---
>
> Note: The dependent kernel patches have been queued into tip/perf/urgent
> tree.
>
> tools/perf/pmu-events/jevents.py | 8 ++++----
> 1 file changed, 4 insertions(+), 4 deletions(-)
>
> diff --git a/tools/perf/pmu-events/jevents.py b/tools/perf/pmu-events/jevents.py
> index 860027bb71b2..93cf04fa8ca4 100755
> --- a/tools/perf/pmu-events/jevents.py
> +++ b/tools/perf/pmu-events/jevents.py
> @@ -249,10 +249,10 @@ class JsonEvent:
> 0x3F6: 'ldlat=',
> 0x1A6: 'offcore_rsp=',
> 0x1A7: 'offcore_rsp=',
> - 0x3E0: 'offcore_rsp=',
> - 0x3E1: 'offcore_rsp=',
> - 0x3E2: 'offcore_rsp=',
> - 0x3E3: 'offcore_rsp=',
> + 0x3E0: 'offmodule_rsp=',
> + 0x3E1: 'offmodule_rsp=',
> + 0x3E2: 'offmodule_rsp=',
> + 0x3E3: 'offmodule_rsp=',
> 0x3F7: 'frontend=',
> }
> return msrmap[int(num.split(',', 1)[0], 0)]
>
> base-commit: edd8a9fe2eca009599e013a29c421c7a6b5ad1b9
> --
> 2.34.1
>