Re: [PATCH v3 06/12] mm/collapse: drop the collapse_possible() wrapper
From: David Hildenbrand (Arm)
Date: Wed Sep 23 2026 - 08:25:52 EST
On 9/16/26 11:31, Kiryl Shutsemau wrote:
> From: "Kiryl Shutsemau (Meta)" <kas@xxxxxxxxxx>
>
> collapse_possible() only forwards to collapse_possible_orders() and turns
> its mask into a bool. Its three callers can test the mask themselves.
>
> No functional change.
>
> Assisted-by: LLM
> Reviewed-by: Zi Yan <ziy@xxxxxxxxxx>
> Reviewed-by: Baolin Wang <baolin.wang@xxxxxxxxxxxxxxxxx>
> Signed-off-by: Kiryl Shutsemau (Meta) <kas@xxxxxxxxxx>
> ---
> mm/khugepaged.c | 15 +++++----------
> 1 file changed, 5 insertions(+), 10 deletions(-)
>
> diff --git a/mm/khugepaged.c b/mm/khugepaged.c
> index cb08789b2d38..62bafe509bb7 100644
> --- a/mm/khugepaged.c
> +++ b/mm/khugepaged.c
> @@ -512,17 +512,11 @@ static unsigned long collapse_possible_orders(struct vm_area_struct *vma,
> return thp_vma_allowable_orders(vma, vm_flags, tva_flags, orders);
> }
>
> -static bool collapse_possible(struct vm_area_struct *vma,
> - vm_flags_t vm_flags, enum tva_type tva_flags)
> -{
> - return collapse_possible_orders(vma, vm_flags, tva_flags);
> -}
I think we added this deliberately to make the code easier to read. I don't care
enough to argue to keep it
Acked-by: David Hildenbrand (Arm) <david@xxxxxxxxxx>
--
Cheers,
David