Re: [RFC PATCH v6 05/11] iommu: Add a helper to validate a vIOMMU parent

From: Jason Gunthorpe

Date: Thu Sep 24 2026 - 15:51:38 EST


> [ ... 18 lines skipped ... ]
> +int iommu_viommu_validate_parent(struct device *dev,
> + enum iommu_viommu_type type, struct iommu_domain *parent_domain)
> +{

I didn't see anything that calls this? I can't imagine what it would
be needed for?

The TSM viommu should use a NULL parent domain, it doesn't have an
iommufd managed S2.

--
Jason