Re: [PATCH 6/8] mtd: rawnand: qcom: make nandc_set_read_loc_last() more generic
From: sashiko-bot
Date: Thu Sep 24 2026 - 16:15:50 EST
Thank you for your contribution! Sashiko AI review found 1 potential issue(s) to consider:
- [Medium] mtd: commit message incorrectly claims 'qpic_nandc' prefix is used
--
commit 640e8b0121507d995cca38494c17f8a44fcdb750
Author: Gabor Juhos <j4g8y7@xxxxxxxxx>
mtd: rawnand: qcom: make nandc_set_read_loc_last() more generic
This commit modifies nandc_set_read_loc_last() to take a qcom_nand_controller
pointer directly instead of a nand_chip pointer, aiming to make it more
generic. It also renames the function as part of a preparation to move it
into common code.
> In order to make the function more generic, change the declaration
> to get a 'qcom_nandc_controller' pointer directly, and update the
> callers accordingly. While at it, also change the function name to
> use a 'qpic_nandc' prefix.
[Severity: Medium]
Does the commit message accurately reflect the new function name? The message
states the function is renamed using a 'qpic_nandc' prefix, but looking at
the changes to drivers/mtd/nand/raw/qcom_nandc.c, the function is actually
renamed to use a 'qcom_nandc' prefix:
> --- a/drivers/mtd/nand/raw/qcom_nandc.c
> +++ b/drivers/mtd/nand/raw/qcom_nandc.c
[ ... ]
> -static void nandc_set_read_loc_last(struct nand_chip *chip,
> - int reg_base, u32 cw_offset,
> - u32 read_size, u32 is_last_read_loc)
> +static void qcom_nandc_set_read_loc_last(struct qcom_nand_controller *nandc,
> + int reg_base, u32 cw_offset,
> + u32 read_size, u32 is_last_read_loc)
Should the commit message be updated to mention 'qcom_nandc' instead, or was
the function intended to be named qpic_nandc_set_read_loc_last()?
--
Sashiko AI review · https://sashiko.dev/#/patchset/20260924-qcom_nandc-share-more-code-v1-0-f3012199b161@xxxxxxxxx?part=6