Re: [PATCH] x86/hpet: Use common error handling code in hpet_create_irq_domain()
From: Habil Eren Türker
Date: Fri Sep 25 2026 - 11:13:42 EST
Hi Markus,
Thanks for the patch.
While consolidating the error paths using gotos can sometimes provide better simplicity and readability in codes, the implicit fall-through from `free_fwnode` label straight into `free_info` feels a bit error-prone for future maintenance.
If someone later modifies the code and uses these labels, it could lead to unintended side effects or a double-free error. Although the syntax of the original code blocks involves repetition, it is readable and safe.
Personally, I believe the original code is cleaner and less risky to maintain in the long run.
Sincerely,
Habil Eren Türker <habilerenturker@xxxxxxxxxxx>