Re: [PATCH 5.15.y v3 3/7] KVM: x86/mmu: Derive shadow MMU page role from parent

From: Sasha Levin

Date: Fri Sep 25 2026 - 14:55:09 EST


> I vote to backport the relevant upstream commits. Reviewing this without those
> commits is a pain. I think it's these, to get fairly clean cherry-picks?
>
> dc1ce45575b3401102568dd60ba8894849d1d64b KVM: MMU: update comment on the number of page role combinations
> 41e35604eaff2266ba8523787ebe99c5ca4c4045 KVM: X86: Remove useless code to set role.gpte_is_8_bytes when role.direct
> b46a13cb7ea1137b2e01dfaafcacd5cd79db8390 KVM: X86: Calculate quadrant when !role.gpte_is_8_bytes
> bb3b394d35e80d7a58ce015191e4960a13f54ba5 KVM: X86: Rename gpte_is_8_bytes to has_4_byte_gpte and invert the direction

Agreed. Those four apply to 5.15 in that order without conflicts.

Kenta, could you send a v4 that starts with them and then carries 3/7 and
4/7 in their upstream has_4_byte_gpte form? 3/7 doesn't apply on top of
them as it is now.

--
Thanks,
Sasha