Re: [PATCH v10 07/19] dmaengine: ti: k3-udma: Add variant-specific function pointers to udma_dev
From: Vignesh Raghavendra
Date: Mon Sep 28 2026 - 04:42:25 EST
> Introduce function pointers in the udma_dev structure to allow
> variant-specific implementations for certain operations.
> This prepares the driver for supporting multiple K3 UDMA variants,
> such as UDMA v2, with minimal code duplication.
>
> No functional changes intended in this commit.
>
> Reviewed-by: Frank Li <Frank.Li@xxxxxxx>
> Signed-off-by: Sai Sree Kartheek Adivi <s-adivi@xxxxxx>
>
> diff --git a/drivers/dma/ti/k3-udma-private.c b/drivers/dma/ti/k3-udma-private.c
> index 624360423ef1..44c097fff5ee 100644
> --- a/drivers/dma/ti/k3-udma-private.c
> +++ b/drivers/dma/ti/k3-udma-private.c
> @@ -8,13 +8,19 @@
>
> int xudma_navss_psil_pair(struct udma_dev *ud, u32 src_thread, u32 dst_thread)
> {
> - return navss_psil_pair(ud, src_thread, dst_thread);
> + if (ud->psil_pair)
> + return ud->psil_pair(ud, src_thread, dst_thread);
> +
> + return 0;
> }
> EXPORT_SYMBOL(xudma_navss_psil_pair);
>
> int xudma_navss_psil_unpair(struct udma_dev *ud, u32 src_thread, u32 dst_thread)
> {
> - return navss_psil_unpair(ud, src_thread, dst_thread);
> + if (ud->psil_unpair)
> + return ud->psil_unpair(ud, src_thread, dst_thread);
> +
> + return 0;
> }
> EXPORT_SYMBOL(xudma_navss_psil_unpair);
Do we need the check for ud->psil_{un}pair to be NULL? I dont see any
patch from v2 driver to xudma_navss_psil_{un}pair()?
--
Vignesh