Re: [PATCH] init: simplify initramfs.o build rule

From: Nicolas Schier

Date: Thu Oct 01 2026 - 12:16:29 EST


On Wed, Sep 30, 2026 at 09:57:48AM +0800, Yuntao Wang wrote:
> CONFIG_BLK_DEV_INITRD is known to be enabled in the else branch,
> so there is no need to use obj-$(CONFIG_BLK_DEV_INITRD). Use obj-y
> directly to make the build rule clearer.
>
> Also, reorder the condition to make the code easier to follow.
>
> No functional change.
>
> Signed-off-by: Yuntao Wang <yuntao.wang@xxxxxxxxx>
> ---
> init/Makefile | 6 +++---
> 1 file changed, 3 insertions(+), 3 deletions(-)

Thanks!

Reviewed-by: Nicolas Schier <nsc@xxxxxxxxxx>

--
Nicolas