Re: [PATCH v3 28/40] mm: rename is_vm_hugetlb_page() to vma_is_hugetlb()
From: David Hildenbrand (Arm)
Date: Fri Oct 02 2026 - 02:55:11 EST
On 9/17/26 18:22, Lorenzo Stoakes (ARM) wrote:
> The is_vm_hugetlb_page() predicate is badly named - the mapping can span
> more than a page and it is inconsistent with other VMA predicates that
> typically are prefixed by vma_.
>
> Rename to vma_is_hugetlb() for consistency, and while we're here update
> some VM_BUG_ON_VMA() to VM_WARN_ON_ONCE_VMA() as to avoid unnecessary
> oopses.
>
> No functional change intended.
>
> Acked-by: Marc Zyngier <maz@xxxxxxxxxx>
> Acked-by: Claudio Imbrenda <imbrenda@xxxxxxxxxxxxx>
> Acked-by: Anup Patel <anup@xxxxxxxxxxxxxx>
> Signed-off-by: Lorenzo Stoakes (ARM) <ljs@xxxxxxxxxx>
> ---
Acked-by: David Hildenbrand (Arm) <david@xxxxxxxxxx>
--
Cheers,
David