Dave,
Final patch with feedback from Henner to change the naming convention of
the return codes. Clean it up, polish it, junk it etc.
I'd like also to send you a large patch or a series of patches to use the
NET_RX_* codes by the protocols. eg patch:
--------------------------------------------------------
--- ip_input.c 2000/09/23 12:48:56 1.1
+++ ip_input.c 2000/09/23 12:52:52
@@ -341,7 +341,7 @@
skb = skb_cow(skb, skb_headroom(skb));
if (skb == NULL)
- return 0;
+ return NET_RX_DROP;
iph = skb->nh.iph;
skb->ip_summed = 0;
@@ -372,7 +372,7 @@
IP_INC_STATS_BH(IpInHdrErrors);
drop:
kfree_skb(skb);
- return(0);
+ return NET_RX_DROP;
}
/*
@@ -429,6 +429,6 @@
drop:
kfree_skb(skb);
out:
- return(0);
+ return NET_RX_DROP;
}
------------------------------------------------------
I realize nobody is using those codes but they would be useful and will
enforce consistency.
cheers,
jamal
This archive was generated by hypermail 2b29 : Sat Sep 30 2000 - 21:00:16 EST